bump version numbers to 1.7.0 and updated changelog
[deb_libcec.git] / debian / changelog
index 0c8443b10356aa4ddae15fa4c62cdf5ce28c5561..11d798e2cb28f664d75947bea185687aa7ca0607 100644 (file)
@@ -1,8 +1,36 @@
-libcec (1.6.1-6) unstable; urgency=low
+libcec (1.7.1-1) unstable; urgency=low
 
-  * updated debian/control to replace libcec (<< 1.6)
+  * changed/added:
+    * added physical address detection via ADL for AMD graphics cards
+    * attempt to get the edid from nvidia's graphics card driver on linux via
+      /proc/acpi/video/NGFX/HDMI/EDID
+    * attempt to get the PA from the registry on windows if we fail to get the
+      physical address from the display driver
+    * changed the order in CCECClient::SetPhysicalAddress() so it first checks
+      whether a PA override is set in libcec_configuration.iPhysicalAddress,
+      then checks whether the address can be detected, and if both failed it'll
+      use the HDMI port + base device setting
+    * cec-client: only active the source when reconnecting if libcec was the
+      active source before closing the connection
+    * platform: added tcp server sockets for posix
+
+  * interface changes:
+    * libcec_configuration.bAutodetectAddress is now read-only, and will be set
+      to 1 by libCEC if the PA was autodetected
+    * LibCecSharp: don't use an int but a CecUserControlCode in a CecKeypress
 
- -- Pulse-Eight Packaging <packaging@pulse-eight.com>  Sat, 26 May 2012 11:22:00 +0100
+  * fixed:
+    * don't unregister clients in CLibCEC when disconnecting, but only in
+      CCECProcessor. fixes reconnect after close
+    * MSGCODE_TIMEOUT_ERROR is a response to a transmission
+    * retry 'activate source' every 10 seconds if it failed
+    * don't respond with a poll from the broadcast address when receiving
+      in CSLCommandHandler::HandleDeviceVendorId(), but use the primary LA of
+      the client as source instead
+    * hold a lock when changing the ackmask in
+      CUSBCECAdapterCommunication::Open
+
+ -- Pulse-Eight Packaging <packaging@pulse-eight.com>  Mon, 4 Jun 2012 10:34:00 +0100
 
 libcec (1.6.1-5) unstable; urgency=low