return HDMI physical address using EDID data retrieved from X11 randr extension
[deb_libcec.git] / src / lib / Makefile.am
index cdc1cbd9279aa860181de522094e716a184fd782..3ac5577961c373ae22b2c79cb9fae2664e04f0ab 100644 (file)
@@ -27,7 +27,8 @@ libcec_la_SOURCES = CECProcessor.cpp \
                     implementations/VLCommandHandler.cpp \
                     implementations/RLCommandHandler.cpp \
                     implementations/PHCommandHandler.cpp \
-                    implementations/RHCommandHandler.cpp
+                    implementations/RHCommandHandler.cpp \
+                    implementations/AQCommandHandler.cpp
 
 ## server sockets, currently unused
 ##libcec_la_SOURCES += platform/posix/serversocket.cpp
@@ -43,6 +44,10 @@ libcec_la_SOURCES += adapter/Pulse-Eight/USBCECAdapterMessage.cpp \
                      platform/posix/os-edid.cpp \
                      platform/adl/adl-edid.cpp \
                      platform/nvidia/nv-edid.cpp
+if USE_X11_RANDR
+libcec_la_SOURCES += platform/X11/randr-edid.cpp
+endif
+
 endif
 
 ## Raspberry Pi support