sharp: check whether the 'auto power on' option is disabled and tell the user how...
[deb_libcec.git] / src / lib / Makefile.am
index 7ea1e99dd5bf742a66149f82c2d624369b535c4a..9117d8ebf3ce8fb7e9880b8b3497b4b8e3b946aa 100644 (file)
@@ -25,7 +25,10 @@ libcec_la_SOURCES = CECProcessor.cpp \
                     implementations/CECCommandHandler.cpp \
                     implementations/SLCommandHandler.cpp \
                     implementations/VLCommandHandler.cpp \
-                    implementations/RLCommandHandler.cpp
+                    implementations/RLCommandHandler.cpp \
+                    implementations/PHCommandHandler.cpp \
+                    implementations/RHCommandHandler.cpp \
+                    implementations/AQCommandHandler.cpp
 
 ## server sockets, currently unused
 ##libcec_la_SOURCES += platform/posix/serversocket.cpp
@@ -50,4 +53,11 @@ libcec_la_SOURCES += adapter/RPi/RPiCECAdapterDetection.cpp \
                      adapter/RPi/RPiCECAdapterMessageQueue.cpp
 endif
 
+## CuBox (NXP) support
+if USE_TDA995X_API
+libcec_la_SOURCES += adapter/TDA995x/TDA995xCECAdapterDetection.cpp \
+                     adapter/TDA995x/TDA995xCECAdapterCommunication.cpp
+endif
+
+
 libcec_la_LDFLAGS = @LIBS_LIBCEC@ -version-info @VERSION@