Add support for Exynos HDMI
[deb_libcec.git] / src / lib / Makefile.am
index b88b02baf1ac1be7f3389fc07ada17d64ee0274c..dd6ade27e3092a52c36dbdd1fe078873e1b9eb5f 100644 (file)
@@ -25,7 +25,10 @@ libcec_la_SOURCES = CECProcessor.cpp \
                     implementations/CECCommandHandler.cpp \
                     implementations/SLCommandHandler.cpp \
                     implementations/VLCommandHandler.cpp \
-                    implementations/RLCommandHandler.cpp
+                    implementations/RLCommandHandler.cpp \
+                    implementations/PHCommandHandler.cpp \
+                    implementations/RHCommandHandler.cpp \
+                    implementations/AQCommandHandler.cpp
 
 ## server sockets, currently unused
 ##libcec_la_SOURCES += platform/posix/serversocket.cpp
@@ -52,9 +55,14 @@ endif
 
 ## CuBox (NXP) support
 if USE_TDA995X_API
-libcec_la_SOURCES += adapter/CuBox/NxpCECAdapterDetection.cpp \
-                     adapter/CuBox/NxpCECAdapterCommunication.cpp
+libcec_la_SOURCES += adapter/TDA995x/TDA995xCECAdapterDetection.cpp \
+                     adapter/TDA995x/TDA995xCECAdapterCommunication.cpp
 endif
 
+## Exynos support
+if USE_EXYNOS_API
+libcec_la_SOURCES += adapter/Exynos/ExynosCECAdapterDetection.cpp \
+                     adapter/Exynos/ExynosCECAdapterCommunication.cpp
+endif
 
 libcec_la_LDFLAGS = @LIBS_LIBCEC@ -version-info @VERSION@