two new classes: Rule, RuleSet
[lsystem3d.git] / src / Makefile.am
index a870324e4b504bbe7a52a6e28a757413bd3ac52c..69b36e077886c65816d1b0fc256e93eded773c56 100644 (file)
@@ -1,15 +1,15 @@
-bin_PROGRAMS = lsystem
-lsystem_SOURCES = lsystem.cpp callbacks.cpp lindenmayersystem.cpp model.cpp \
-               openglwindow.cpp turtle.cpp vector.cpp xmlstructure.cpp lsystemparameters.cpp \
-       coordinate.cpp
+bin_PROGRAMS = lsystem3d
+lsystem3d_SOURCES = lsystem.cpp lindenmayersystem.cpp model.cpp turtle.cpp \
+       vector.cpp xmlstructure.cpp lsystemparameters.cpp coordinate.cpp lsystem3d.cpp \
+       renderingsurface.cpp gui.cpp color.cpp ruleset.cpp rule.cpp
 
 # set the include path found by configure
-INCLUDES = `pkg-config libxml++-2.6 --cflags` $(all_includes)
+INCLUDES = `fox-config --cflags` `pkg-config libxml++-2.6 --cflags` \
+       $(all_includes)
 
 # the library search path.
-lsystem_LDFLAGS = $(all_libraries) -lglui -lglut -lGLU -lGL `pkg-config \
-       libxml++-2.6 --libs`
-noinst_HEADERS = callbacks.h lindenmayersystem.h model.h openglwindow.h \
-               turtle.h vector.h xmlstructure.h lsystemparameters.h coordinate.h
-
-noinst_DATA = lsystem.xml
+lsystem3d_LDFLAGS = $(all_libraries) `pkg-config libxml++-2.6 --libs` \
+       `fox-config --libs`
+noinst_HEADERS = lindenmayersystem.h model.h turtle.h vector.h xmlstructure.h \
+       lsystemparameters.h coordinate.h lsystem.xml lsystem3d.h renderingsurface.h gui.h color.h \
+       ruleset.h rule.h