*** empty log message ***
[lsystem3d.git] / src / Makefile.am
index 909976e1800cac32b57e6892ee2bba680411f635..ed9bc07e5d1b1c6a87312e8590410b7b68f5c37c 100644 (file)
@@ -1,13 +1,14 @@
 bin_PROGRAMS = lsystem3d
-lsystem3d_SOURCES = lsystem.cpp callbacks.cpp lindenmayersystem.cpp model.cpp \
-               openglwindow.cpp turtle.cpp vector.cpp xmlstructure.cpp lsystemparameters.cpp \
-       coordinate.cpp
+lsystem3d_SOURCES = lsystem.cpp lindenmayersystem.cpp model.cpp turtle.cpp \
+               vector.cpp xmlstructure.cpp lsystemparameters.cpp coordinate.cpp lsystem3d.cpp \
+               renderingsurface.cpp gui.cpp color.cpp
 
 # set the include path found by configure
-INCLUDES = `pkg-config libxml++-2.6 --cflags` $(all_includes)
+INCLUDES = `fox-config --cflags` `pkg-config libxml++-2.6 --cflags` \
+       $(all_includes)
 
 # the library search path.
-lsystem3d_LDFLAGS = $(all_libraries) -lglui -lglut -lGLU -lGL `pkg-config \
-       libxml++-2.6 --libs`
-noinst_HEADERS = callbacks.h lindenmayersystem.h model.h openglwindow.h \
-               turtle.h vector.h xmlstructure.h lsystemparameters.h coordinate.h lsystem.xml
+lsystem3d_LDFLAGS = $(all_libraries) `pkg-config libxml++-2.6 --libs` \
+       `fox-config --libs`
+noinst_HEADERS = lindenmayersystem.h model.h turtle.h vector.h xmlstructure.h \
+               lsystemparameters.h coordinate.h lsystem.xml lsystem3d.h renderingsurface.h gui.h color.h