New version 1.8
[deb_libnfs.git] / lib / Makefile.am
index ba0eb433e7dee0fb57ee63c54fcb39885d041cd4..4a51bc710d247b701318086ea71955bd63205a99 100644 (file)
@@ -1,23 +1,27 @@
 lib_LTLIBRARIES = libnfs.la
 
 libnfs_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
-                    -I$(abs_top_srcdir)/mount \
-                    -I$(abs_top_srcdir)/nfs \
-                    -I$(abs_top_srcdir)/portmap \
-                    -I$(abs_top_srcdir)/rquota \
+                    -I$(abs_top_srcdir)/include/nfsc \
+                    -I../mount \
+                    -I../nfs \
+                    -I../nlm \
+                    -I../portmap \
+                    -I../rquota \
                     "-D_U_=__attribute__((unused))"
 
 libnfs_la_SOURCES = \
        init.c \
        libnfs.c \
        libnfs-sync.c \
+       libnfs-zdr.c \
        pdu.c \
        socket.c
 
-libnfs_la_LDFLAGS = -version-info 0:0:0
+libnfs_la_LDFLAGS = -version-info 1:8:0
 libnfs_la_LIBADD = \
-       $(abs_top_srcdir)/mount/libmount.la \
-       $(abs_top_srcdir)/nfs/libnfs.la \
-       $(abs_top_srcdir)/portmap/libportmap.la \
-       $(abs_top_srcdir)/rquota/librquota.la 
+       ../mount/libmount.la \
+       ../nfs/libnfs.la \
+       ../nlm/libnlm.la \
+       ../portmap/libportmap.la \
+       ../rquota/librquota.la