RPC: get rid of references to SCVXPRT
[deb_libnfs.git] / mount / Makefile.am
index 9dadbf8bfc2c6a477aeceac85e544b547be8b79c..13cbaf46f90e2a90a818b69a94e81dfe329c5221 100644 (file)
@@ -10,13 +10,15 @@ libmount_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
                       -I$(abs_top_srcdir)/include/nfsc
 libmount_la_SOURCES = \
        $(mount_SOURCES_GENERATED) \
-       mount.c libnfs-raw-mount.c
+       mount.c libnfs-raw-mount.c libnfs-raw-mount.h
 
 $(mount_GENERATED) : mount-stamp
 mount-stamp : mount.x
        rm -f $(mount_GENERATED)
        touch mount-stamp
 
-compile_rpc:   
-       rpcgen -h mount.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-mount.h
-       rpcgen -c mount.x | sed -e "s/#include \".*mount.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-mount.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n      buf = NULL;/" > libnfs-raw-mount.c
+compile_rpc:
+       cat mount.x | head -29 >libnfs-raw-mount.h
+       rpcgen -h mount.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" >> libnfs-raw-mount.h
+       cat mount.x | head -29 >libnfs-raw-mount.c
+       rpcgen -c mount.x | sed -e "s/#include \".*mount.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-mount.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n      buf = NULL;/" >> libnfs-raw-mount.c