Remove all remaining references to RPC
[deb_libnfs.git] / mount / Makefile.am
index c0633169263d1ea129bdb507697cda7aaa4c5696..9dadbf8bfc2c6a477aeceac85e544b547be8b79c 100644 (file)
@@ -6,7 +6,8 @@ mount_GENERATED = $(mount_SOURCES_GENERATED) $(mount_HEADERS_GENERATED)
 
 CLEANFILES = $(mount_GENERATED) mount-stamp
 
-libmount_la_CPPFLAGS = -I$(abs_top_srcdir)/include
+libmount_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
+                      -I$(abs_top_srcdir)/include/nfsc
 libmount_la_SOURCES = \
        $(mount_SOURCES_GENERATED) \
        mount.c libnfs-raw-mount.c
@@ -17,5 +18,5 @@ mount-stamp : mount.x
        touch mount-stamp
 
 compile_rpc:   
-       rpcgen -h @RPCGENFLAGS@ mount.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-mount.h
-       rpcgen -c @RPCGENFLAGS@ mount.x | sed -e "s/#include \".*mount.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-mount.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n        buf = NULL;/" > libnfs-raw-mount.c
+       rpcgen -h mount.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-mount.h
+       rpcgen -c mount.x | sed -e "s/#include \".*mount.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-mount.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n      buf = NULL;/" > libnfs-raw-mount.c