ZDR: New builtin replacement for RPC/XDR called ZDR
[deb_libnfs.git] / mount / Makefile.am
index 19cbaee7eb3b483ccf00daa26e291b2671a7edde..b14568a0b4bf4b2be38edeacadf694069374cd0b 100644 (file)
@@ -1,7 +1,7 @@
 noinst_LTLIBRARIES = libmount.la
 
-mount_SOURCES_GENERATED = libnfs-raw-mount.c
-mount_HEADERS_GENERATED = libnfs-raw-mount.h
+mount_SOURCES_GENERATED =
+mount_HEADERS_GENERATED =
 mount_GENERATED = $(mount_SOURCES_GENERATED) $(mount_HEADERS_GENERATED)
 
 CLEANFILES = $(mount_GENERATED) mount-stamp
@@ -9,12 +9,13 @@ CLEANFILES = $(mount_GENERATED) mount-stamp
 libmount_la_CPPFLAGS = -I$(abs_top_srcdir)/include
 libmount_la_SOURCES = \
        $(mount_SOURCES_GENERATED) \
-       mount.c
+       mount.c libnfs-raw-mount.c
 
 $(mount_GENERATED) : mount-stamp
 mount-stamp : mount.x
        rm -f $(mount_GENERATED)
-       rpcgen -h @RPCGENFLAGS@ $< > libnfs-raw-mount.h
-       rpcgen -c @RPCGENFLAGS@ $< | sed -e "s/#include \".*mount.h\"/#include \"libnfs-raw-mount.h\"/" > libnfs-raw-mount.c
        touch mount-stamp
-       
+
+compile_rpc:   
+       rpcgen -h @RPCGENFLAGS@ mount.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-mount.h
+       rpcgen -c @RPCGENFLAGS@ mount.x | sed -e "s/#include \".*mount.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-mount.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-mount.c
\ No newline at end of file