Use our own xdr_int64() for all 64 bit types.
[deb_libnfs.git] / nlm / Makefile.am
index 7ec82da9710533d605b3a5f1510a5b5550aec7ea..0873dda10bdad54494ae9de4a42846d3f7a847e7 100644 (file)
@@ -15,6 +15,6 @@ $(nlm_GENERATED) : nlm-stamp
 nlm-stamp : nlm.x
        rm -f $(nlm_GENERATED)
        rpcgen -h @RPCGENFLAGS@ $< > libnfs-raw-nlm.h
-       rpcgen -c @RPCGENFLAGS@ $< | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-raw-nlm.h\"/" > libnfs-raw-nlm.c
+       rpcgen -c @RPCGENFLAGS@ $< | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-raw-nlm.h\"/" -e "s/^xdr_uint64/static xdr_uint64_broken/" > libnfs-raw-nlm.c
        touch nlm-stamp