Update how the rpc files are generated so we dont get "unused variable" for *buf
[deb_libnfs.git] / nlm / Makefile.am
index 6945c1ba64a2b7826c574b1d3869e93fb2eaaa4e..19391bd3f709435feb4d5c613b7543540892df94 100644 (file)
@@ -18,4 +18,4 @@ nlm-stamp : nlm.x
 
 compile_rpc:   
        rpcgen -h @RPCGENFLAGS@ nlm.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-nlm.h
-       rpcgen -c @RPCGENFLAGS@ nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g"  > libnfs-raw-nlm.c
+       rpcgen -c @RPCGENFLAGS@ nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n      buf = NULL;/" > libnfs-raw-nlm.c