RPC: get rid of bool_t
[deb_libnfs.git] / nlm / Makefile.am
index 93b3c86d27f7e58294448e979c30ce752d8a324a..3ed74b755fc33a616174bd59e2be737236a5aa8c 100644 (file)
@@ -19,6 +19,6 @@ nlm-stamp : nlm.x
 
 compile_rpc:   
        cat nlm.x | head -29 >libnfs-raw-nlm.h
-       rpcgen -h nlm.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" >> libnfs-raw-nlm.h
+       rpcgen -h nlm.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" -e "s/bool_t/uint32_t/g" >> libnfs-raw-nlm.h
        cat nlm.x | head -29 >libnfs-raw-nlm.c
-       rpcgen -c nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n    buf = NULL;/" >> libnfs-raw-nlm.c
+       rpcgen -c nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n    buf = NULL;/" -e "s/bool_t/uint32_t/g" >> libnfs-raw-nlm.c