RPC: get rid of references to SCVXPRT
[deb_libnfs.git] / nlm / Makefile.am
index d6dd13cd078ca0c8e59fbced8f5f7093efeacd17..93b3c86d27f7e58294448e979c30ce752d8a324a 100644 (file)
@@ -10,7 +10,7 @@ libnlm_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
                     -I$(abs_top_srcdir)/include/nfsc
 libnlm_la_SOURCES = \
        $(nlm_SOURCES_GENERATED) \
-       nlm.c libnfs-raw-nlm.c
+       nlm.c libnfs-raw-nlm.c libnfs-raw-nlm.h
 
 $(nlm_GENERATED) : nlm-stamp
 nlm-stamp : nlm.x
@@ -18,5 +18,7 @@ nlm-stamp : nlm.x
        touch nlm-stamp
 
 compile_rpc:   
-       rpcgen -h nlm.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-nlm.h
-       rpcgen -c nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n    buf = NULL;/" > libnfs-raw-nlm.c
+       cat nlm.x | head -29 >libnfs-raw-nlm.h
+       rpcgen -h nlm.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" >> libnfs-raw-nlm.h
+       cat nlm.x | head -29 >libnfs-raw-nlm.c
+       rpcgen -c nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n    buf = NULL;/" >> libnfs-raw-nlm.c