Simplify the upgrade path handling from PPA.
[deb_libnfs.git] / nlm / Makefile.am
index 19391bd3f709435feb4d5c613b7543540892df94..dd91cb97f707837e6f1724cdf1e9f546c2d97504 100644 (file)
@@ -6,10 +6,11 @@ nlm_GENERATED = $(nlm_SOURCES_GENERATED) $(nlm_HEADERS_GENERATED)
 
 CLEANFILES = $(nlm_GENERATED) nlm-stamp
 
-libnlm_la_CPPFLAGS = -I$(abs_top_srcdir)/include
+libnlm_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
+                    -I$(abs_top_srcdir)/include/nfsc
 libnlm_la_SOURCES = \
        $(nlm_SOURCES_GENERATED) \
-       nlm.c libnfs-raw-nlm.c
+       nlm.c libnfs-raw-nlm.c libnfs-raw-nlm.h
 
 $(nlm_GENERATED) : nlm-stamp
 nlm-stamp : nlm.x
@@ -17,5 +18,7 @@ nlm-stamp : nlm.x
        touch nlm-stamp
 
 compile_rpc:   
-       rpcgen -h @RPCGENFLAGS@ nlm.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-nlm.h
-       rpcgen -c @RPCGENFLAGS@ nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n      buf = NULL;/" > libnfs-raw-nlm.c
+       cat nlm.x | head -29 >libnfs-raw-nlm.h
+       rpcgen -h nlm.x | sed -e "s/#include <rpc\/rpc.h>/#include <nfsc\/libnfs-zdr.h>/" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" -e "s/bool_t/uint32_t/g" >> libnfs-raw-nlm.h
+       cat nlm.x | head -29 >libnfs-raw-nlm.c
+       rpcgen -c nlm.x | sed -e "s/#include \".*nlm.h\"/#include \"libnfs-xdr.h\"\n#include \"libnfs-raw-nlm.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n    buf = NULL;/" -e "s/bool_t/uint32_t/g" >> libnfs-raw-nlm.c