Imported Upstream version 1.9.5
[deb_libnfs.git] / portmap / Makefile.am
index 682ca2ac5a6695fbe6a0aae59f5b567c2e365880..5fcccfa43f39af5bee1c14e7857239a6d52034cd 100644 (file)
@@ -19,6 +19,6 @@ portmap-stamp : portmap.x
 
 compile_rpc:   
        cat portmap.x | head -29 >libnfs-raw-portmap.h
-       rpcgen -h portmap.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" >> libnfs-raw-portmap.h
+       rpcgen -h portmap.x | sed -e "s/#include <rpc\/rpc.h>/#include <nfsc\/libnfs-zdr.h>/" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" -e "s/bool_t/uint32_t/g" >> libnfs-raw-portmap.h
        cat portmap.x | head -29 >libnfs-raw-portmap.c
-       rpcgen -c portmap.x | sed -e "s/#include \".*portmap.h\"/#include \"libnfs-zdr.h\"\n#include \"libnfs-raw-portmap.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n        buf = NULL;/" >> libnfs-raw-portmap.c
+       rpcgen -c portmap.x | sed -e "s/#include \".*portmap.h\"/#include \"libnfs-zdr.h\"\n#include \"libnfs-raw-portmap.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n        buf = NULL;/" -e "s/bool_t/uint32_t/g" >> libnfs-raw-portmap.c