RPC: get rid of references to SCVXPRT
[deb_libnfs.git] / portmap / Makefile.am
index 5b218702bce51eca2fa98002d44c254d9443f5fe..71801bd8ff7a3774b741fdc022d097a21afd50f9 100644 (file)
@@ -10,7 +10,7 @@ libportmap_la_CPPFLAGS = -I$(abs_top_srcdir)/include \
                         -I$(abs_top_srcdir)/include/nfsc
 libportmap_la_SOURCES = \
        $(portmap_SOURCES_GENERATED) \
-       portmap.c libnfs-raw-portmap.c
+       portmap.c libnfs-raw-portmap.c libnfs-raw-portmap.h
 
 $(portmap_GENERATED) : portmap-stamp
 portmap-stamp : portmap.x
@@ -18,5 +18,7 @@ portmap-stamp : portmap.x
        touch portmap-stamp
 
 compile_rpc:   
-       rpcgen -h @RPCGENFLAGS@ portmap.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" > libnfs-raw-portmap.h
-       rpcgen -c @RPCGENFLAGS@ portmap.x | sed -e "s/#include \".*portmap.h\"/#include \"libnfs-zdr.h\"\n#include \"libnfs-raw-portmap.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n  buf = NULL;/" > libnfs-raw-portmap.c
+       cat portmap.x | head -29 >libnfs-raw-portmap.h
+       rpcgen -h portmap.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" >> libnfs-raw-portmap.h
+       cat portmap.x | head -29 >libnfs-raw-portmap.c
+       rpcgen -c portmap.x | sed -e "s/#include \".*portmap.h\"/#include \"libnfs-zdr.h\"\n#include \"libnfs-raw-portmap.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n        buf = NULL;/" >> libnfs-raw-portmap.c