RPC: get rid of bool_t
[deb_libnfs.git] / portmap / Makefile.am
index 71801bd8ff7a3774b741fdc022d097a21afd50f9..a1d9c07949480fdf4334920147b6ffd56208f5a1 100644 (file)
@@ -19,6 +19,6 @@ portmap-stamp : portmap.x
 
 compile_rpc:   
        cat portmap.x | head -29 >libnfs-raw-portmap.h
-       rpcgen -h portmap.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" >> libnfs-raw-portmap.h
+       rpcgen -h portmap.x | sed -e "s/#include <rpc\/rpc.h>//" | sed -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/ CLIENT / void /g" -e "s/SVCXPRT /void /g" -e "s/bool_t/uint32_t/g" >> libnfs-raw-portmap.h
        cat portmap.x | head -29 >libnfs-raw-portmap.c
-       rpcgen -c portmap.x | sed -e "s/#include \".*portmap.h\"/#include \"libnfs-zdr.h\"\n#include \"libnfs-raw-portmap.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n        buf = NULL;/" >> libnfs-raw-portmap.c
+       rpcgen -c portmap.x | sed -e "s/#include \".*portmap.h\"/#include \"libnfs-zdr.h\"\n#include \"libnfs-raw-portmap.h\"/" -e "s/xdr/zdr/g" -e "s/XDR/ZDR/g" -e "s/register int32_t \*buf;/register int32_t *buf;\n        buf = NULL;/" -e "s/bool_t/uint32_t/g" >> libnfs-raw-portmap.c