ODROID-U3 xorg-server debian package fork :
[deb_xorg-server.git] / debian / patches / 02_kbsd-input-devd.diff
index bdadae2d36bb42769d18cd4ca857aa3e492c730c..790102b41f9b445e08e823a5556f7b21e87d229b 100644 (file)
@@ -19,10 +19,8 @@ Signed-off-by: Robert Millan <rmh@freebsd.org>
  8 files changed, 427 insertions(+), 3 deletions(-)
  create mode 100644 config/devd.c
 
-Index: xorg-server/config/Makefile.am
-===================================================================
---- xorg-server.orig/config/Makefile.am
-+++ xorg-server/config/Makefile.am
+--- a/config/Makefile.am
++++ b/config/Makefile.am
 @@ -40,6 +40,10 @@ if CONFIG_WSCONS
  libconfig_la_SOURCES += wscons.c
  endif # CONFIG_WSCONS
@@ -34,10 +32,8 @@ Index: xorg-server/config/Makefile.am
  endif # CONFIG_NEED_DBUS
  
  endif # !CONFIG_UDEV
-Index: xorg-server/config/config-backends.h
-===================================================================
---- xorg-server.orig/config/config-backends.h
-+++ xorg-server/config/config-backends.h
+--- a/config/config-backends.h
++++ b/config/config-backends.h
 @@ -75,3 +75,8 @@ void config_hal_fini(void);
  int config_wscons_init(void);
  void config_wscons_fini(void);
@@ -47,10 +43,8 @@ Index: xorg-server/config/config-backends.h
 +int config_devd_init(void);
 +void config_devd_fini(void);
 +#endif
-Index: xorg-server/config/config.c
-===================================================================
---- xorg-server.orig/config/config.c
-+++ xorg-server/config/config.c
+--- a/config/config.c
++++ b/config/config.c
 @@ -64,6 +64,9 @@ config_init(void)
  #elif defined(CONFIG_WSCONS)
      if (!config_wscons_init())
@@ -70,10 +64,8 @@ Index: xorg-server/config/config.c
  #endif
  }
  
-Index: xorg-server/config/devd.c
-===================================================================
 --- /dev/null
-+++ xorg-server/config/devd.c
++++ b/config/devd.c
 @@ -0,0 +1,387 @@
 +/*
 + * Copyright © 2012 Baptiste Daroussin
@@ -462,10 +454,8 @@ Index: xorg-server/config/devd.c
 +    RemoveBlockAndWakeupHandlers(block_handler, wakeup_handler, NULL);
 +    close(sock_devd);
 +}
-Index: xorg-server/configure.ac
-===================================================================
---- xorg-server.orig/configure.ac
-+++ xorg-server/configure.ac
+--- a/configure.ac
++++ b/configure.ac
 @@ -618,6 +618,7 @@ AC_ARG_ENABLE(config-udev,    AS_HELP_ST
  AC_ARG_ENABLE(config-udev-kms,    AS_HELP_STRING([--enable-config-udev-kms], [Build udev kms support (default: auto)]), [CONFIG_UDEV_KMS=$enableval], [CONFIG_UDEV_KMS=auto])
  AC_ARG_ENABLE(config-dbus,    AS_HELP_STRING([--enable-config-dbus], [Build D-BUS API support (default: no)]), [CONFIG_DBUS_API=$enableval], [CONFIG_DBUS_API=no])
@@ -496,10 +486,8 @@ Index: xorg-server/configure.ac
  if test "x$USE_SIGIO_BY_DEFAULT" = xyes; then
        USE_SIGIO_BY_DEFAULT_VALUE=TRUE
  else
-Index: xorg-server/hw/xfree86/common/xf86Config.c
-===================================================================
---- xorg-server.orig/hw/xfree86/common/xf86Config.c
-+++ xorg-server/hw/xfree86/common/xf86Config.c
+--- a/hw/xfree86/common/xf86Config.c
++++ b/hw/xfree86/common/xf86Config.c
 @@ -1377,15 +1377,18 @@ checkCoreInputDevices(serverLayoutPtr se
      }
  
@@ -521,10 +509,8 @@ Index: xorg-server/hw/xfree86/common/xf86Config.c
  #endif
          xf86Msg(X_INFO, "The server relies on %s to provide the list of "
                  "input devices.\n\tIf no devices become available, "
-Index: xorg-server/hw/xfree86/common/xf86Globals.c
-===================================================================
---- xorg-server.orig/hw/xfree86/common/xf86Globals.c
-+++ xorg-server/hw/xfree86/common/xf86Globals.c
+--- a/hw/xfree86/common/xf86Globals.c
++++ b/hw/xfree86/common/xf86Globals.c
 @@ -123,7 +123,8 @@ xf86InfoRec xf86Info = {
      .log = LogNone,
      .disableRandR = FALSE,
@@ -535,10 +521,8 @@ Index: xorg-server/hw/xfree86/common/xf86Globals.c
      .forceInputDevices = FALSE,
      .autoAddDevices = TRUE,
      .autoEnableDevices = TRUE,
-Index: xorg-server/include/dix-config.h.in
-===================================================================
---- xorg-server.orig/include/dix-config.h.in
-+++ xorg-server/include/dix-config.h.in
+--- a/include/dix-config.h.in
++++ b/include/dix-config.h.in
 @@ -420,6 +420,9 @@
  /* Support HAL for hotplug */
  #undef CONFIG_HAL