ODROID-U3 xorg-server debian package fork :
[deb_xorg-server.git] / debian / patches / 191-Xorg-add-an-extra-module-path.patch
index 6ff6c3065a399915c94211b9b3ed55f0070b35bb..99d153dc935e15bfba4d8aefddb17b99eedcd33d 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/configure.ac b/configure.ac
-index 2693ce7..44780a2 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -467,6 +467,10 @@ AC_ARG_WITH(module-dir,      AS_HELP_STRING([--with-module-dir=DIR],
+@@ -466,6 +466,10 @@ AC_ARG_WITH(module-dir,      AS_HELP_STR
                                  [Directory where modules are installed (default: $libdir/xorg/modules)]),
                                [ moduledir="$withval" ],
                                [ moduledir="${libdir}/xorg/modules" ])
@@ -13,7 +11,7 @@ index 2693ce7..44780a2 100644
  AC_ARG_WITH(log-dir,         AS_HELP_STRING([--with-log-dir=DIR],
                                  [Directory where log files are kept (default: $localstatedir/log)]),
                                [ logdir="$withval" ],
-@@ -1751,6 +1755,7 @@ if test "x$XORG" = xyes; then
+@@ -2039,6 +2043,7 @@ if test "x$XORG" = xyes; then
        AC_DEFINE_DIR(XF86CONFIGFILE, XF86CONFIGFILE, [Name of configuration file])
        AC_DEFINE_DIR(__XCONFIGDIR__, XF86CONFIGDIR, [Name of configuration directory])
        AC_DEFINE_DIR(DEFAULT_MODULE_PATH, moduledir, [Default module search path])
@@ -21,11 +19,9 @@ index 2693ce7..44780a2 100644
        AC_DEFINE_DIR(DEFAULT_LIBRARY_PATH, libdir, [Default library install path])
        AC_DEFINE_DIR(DEFAULT_LOGPREFIX, LOGPREFIX, [Default log location])
        AC_DEFINE_UNQUOTED(__VENDORDWEBSUPPORT__, ["$VENDOR_WEB"], [Vendor web address for support])
-diff --git a/hw/xfree86/common/xf86Config.c b/hw/xfree86/common/xf86Config.c
-index ec679df..8ae85ab 100644
 --- a/hw/xfree86/common/xf86Config.c
 +++ b/hw/xfree86/common/xf86Config.c
-@@ -647,11 +647,22 @@ configFiles(XF86ConfFilesPtr fileconf)
+@@ -640,11 +640,22 @@ configFiles(XF86ConfFilesPtr fileconf)
  
      /* ModulePath */
  
@@ -50,11 +46,9 @@ index ec679df..8ae85ab 100644
      }
  
      xf86Msg(xf86ModPathFrom, "ModulePath set to \"%s\"\n", xf86ModulePath);
-diff --git a/hw/xfree86/common/xf86Globals.c b/hw/xfree86/common/xf86Globals.c
-index 0071004..13c403f 100644
 --- a/hw/xfree86/common/xf86Globals.c
 +++ b/hw/xfree86/common/xf86Globals.c
-@@ -136,6 +136,7 @@ xf86InfoRec xf86Info = {
+@@ -143,6 +143,7 @@ xf86InfoRec xf86Info = {
  const char *xf86ConfigFile = NULL;
  const char *xf86ConfigDir = NULL;
  const char *xf86ModulePath = DEFAULT_MODULE_PATH;
@@ -62,11 +56,9 @@ index 0071004..13c403f 100644
  MessageType xf86ModPathFrom = X_DEFAULT;
  const char *xf86LogFile = DEFAULT_LOGPREFIX;
  MessageType xf86LogFileFrom = X_DEFAULT;
-diff --git a/hw/xfree86/common/xf86Priv.h b/hw/xfree86/common/xf86Priv.h
-index 8d9cb55..fc057b3 100644
 --- a/hw/xfree86/common/xf86Priv.h
 +++ b/hw/xfree86/common/xf86Priv.h
-@@ -77,6 +77,7 @@ extern _X_EXPORT const char *xf86ServerName;
+@@ -77,6 +77,7 @@ extern _X_EXPORT const char *xf86ServerN
  
  extern _X_EXPORT xf86InfoRec xf86Info;
  extern _X_EXPORT const char *xf86ModulePath;
@@ -74,8 +66,6 @@ index 8d9cb55..fc057b3 100644
  extern _X_EXPORT MessageType xf86ModPathFrom;
  extern _X_EXPORT const char *xf86LogFile;
  extern _X_EXPORT MessageType xf86LogFileFrom;
-diff --git a/include/xorg-config.h.in b/include/xorg-config.h.in
-index 2cc416a..4722023 100644
 --- a/include/xorg-config.h.in
 +++ b/include/xorg-config.h.in
 @@ -42,6 +42,9 @@